Tutorial

How to fix a Windows PC that slows down significantly (lags) when connected to power (charging)

windows hanging when connected to AC power supply

 

A while back, I bought a Dual OS Tablet just to test-run and possibly drop helpful tutorials for users. I’ve been enjoying the device but had been having one major headache; it kept lagging while in Windows 10 mode. On Booting the dual OS tablet into Android, everything seemed to work fine. The lagging would get so bad that Windows became unusable and I would have to restart the tablet. The sad part was that restarting didn’t do much. A few minutes into use and Windows 10 would come to a grinding halt.

I began by resetting Windows 10 . Everything seemed to work for a while and I was happy but my relief was short-lived as the lagging resurfaced.  Antimalware Service Executable seemed to consume a lot of Memory and CPU so I decided to disable Windows Defender; didn’t help either. It couldn’t have been a hardware defect because Android mode was working fine, but I still couldn’t rule this out.

At this point, I knew I had to begin looking out for a pattern so I switched to my Eagle Eye mode. I finally noticed that the lagging began whenever the phone was connected to power. What a relief! I had at least narrowed down the possible source. At this point, I suspected it was a charger issue, trying a different charger didn’t help. Uninstalling Microsoft ACPI-Compliant Control Method Battery under Device Manager didn’t help. It began looking a little more like a hardware issue.

Sponsored Links

 

My thought was, what happens when the phone is connected to power? That was quite easy to answer; restricted processes swing to action since power saving is turned off. Referring to my previous guide on how to fix a slow or lagging PC, my focus shifted to startup and running services.

Next on the agenda was Startup under Task Manager (Ctrl + Alt+ Del) then General and Startup under System Configuration (Search for msconfig.exe from the Windows Start Menu and run as Administrator). Under System Configuration > General,  I set Startup Selection to Selective startup and unticked Load startup items. Under Services, I ticked Hide all Microsoft services and then disabled services I didn’t think were needed, clicked Apply and OK then restarted the PC. That did the trick!

Click to comment

Leave a Reply

Your email address will not be published. Required fields are marked *

To Top

Follow us on Facebook!